
                                 

 Tutorial on create terrain and photo
realistic scenery for Condor 2.

Rev 1, 3/6/2019 – John Murtari (john@murtari.org)

This document provides a step-by-step tutorial on how to create both 3D terrain and photo-realistic 
scenery for use in Condor 2.  

CREDITS:  Many thanks to Mr. Luis Briones (a member of a Flying Club in Argentina), and special 
thanks to Mr. Nick Bonniere, a long-time Condor scenery pro who created a Condor 2 scenery for Lake
Placid.  Nick developed the Condor_tiles program and is making it free for non-commercial use.   He 
also sent me a lot of notes/description used in the tutorial.

Updates and revisions to this document are welcome.  Just send to the author and you’ll be included in 
the Credits.
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Goal:  Create a scenery for the USAF Academy.
This tutorial will take you thru all the steps that were used to create a scenery for the USAF Academy 
in Colorado.   Large sceneries at high resolution take a lot of processing power and time.  In this case 
we’ll be creating a 52x52 mile landscape with the USAFA airfield at the center.

At the end of this tutorial we’ll have flyable scenery with 3-D terrain which has been overlaid by photo 
scenery.  For those of you who have used Condor, it will NOT have any actual 3-D objects like trees, 
hangars, runways.  We will not do any special thermal modeling.  Hopefully, those additions to this 
tutorial will come later (maybe from you!)…

Part One:  Creation of 3-D terrain
This part will first get your computer setup for landscape creation with the needed landscape creation 
tools and documentation.   We’ll then go thru the steps necessary to create a flyable 3-D terrain of the 
correct size

Step Zero:   Download the tools and guides needed

If you’re a Mac/Apple person, sorry, most of these tools only run under Windows.  Graphics 
processing is a difficult task for a PC.  You should have a reasonably fast processor and at least 8 
Gigabytes of RAM and room on your hard drive.  A completed scenery can easily use several 
Gigabytes of disk space.

1) Download the tool set and documentation for landscapes from the condorsoaring.com site, unpack in
a different directory from where Condor2 is installed

2) Download and install the QGIS program version2.18.28, x64 from → 
http://download.osgeo.org/qgis/ .  We won’t use most of it, but one of the utilities it contains will be 
used by Condor_tiles later.

3) Download the Condor_tiles program and unpack.

        

Step One:  Determine the coordinates for the scenery
Use this to find your Universal Transverse Mercator Zone (UTM) and measure distances →  

https://mangomap.com/robertyoung/maps/69585/what-utm-zone-am-i-in- 

The goal is to determine your UTM zone and then the latitude/longitude of the north west 
corner and south east corner of your landscape (also know as top left  and bottom right).  NOTE:  You 
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don’t want your landscape to cross zones – that is beyond the scope of this tutorial (for now).

For the USAF Academy we’re doing a 9 tile landscape (3 x 3).  Each Condor landscape tile is 
14.29 miles/14.29 miles, do we want to have a square app. 42 miles on each side.  Now remember, the 
Earth is not FLAT, so our square is approximate and the tools will compensate for that.

You can use the UTM lookup site above for that, also Google Earth is very handy.   Here is 
what we have for the USAF Academy and the yellow pins define the two corners.  Take the time to 
make SURE you get the coordinates right.  In this case we have the below.  BE CAREFUL not to 
confused Degrees/Decimal miinutes/seconds below with other format which give individual degrees, 
minutes, seconds.  Some tools like a certain format – many are happy to take the wrong format and 
convert to a bad location….. beware!

This web site is your FRIEND in conversions →   https://www.pgc.umn.edu/apps/convert/         

NW Pt:   39°16'18"N / 105°12'58"W or 39°16.3’N / 105°12.96’W or 39.271667 / -105.216112

SE Pt: 38°38'39"N /  104°25'37"W or 38°38.65’N / 104°25.61’W or 38.644167 / -104.426944

WARNING: Don’t skimp on this step, some bad numbers here will cost you later!
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Step Two:  Convert to UTM coordinates, confirm proper size

With those corners defined, we can now start to build the landscape.  The Lat/Lon we have are 
approximate.  We not need to get exact numbers by converting to UTM and making sure we are on a 
boundary.

1) Start Condor_Tiles.  On just the first run you need to define two paths. Using the ‘Browse’ buttons

Condor_Path → Set it to the location of your Condor2 install, usually C:\Condor2

GDAL library Path → This is a geodata processing package that was installed as part of QGIS. 
If you’ve installed QGIS 2.18 you should find this path:  C:\Program Files\QGIS 2.18\bin
If you’re having a hard time finding it, do a Windows search for gdalwarp.exe

Mine looks like this when done.  The displayed paths look incomplete, but it’s all ther.

2)   In Condor_tiles click on the “DEM Helper” button in the lower right. This will bring up a new 
screen.  Make the following entries:

       a) In the bottom left “Range Margin” choose “None” (we should have already compensated that
the last 5.76Km or 3.6 miles will be unflyable around the border of your landscape).

      b) In the upper left “Desired Area Selection” choose “By Coordinates” and enter the values just 
as we recorded earlier.  Use the degree/decimal values.

c)  Then click the box ‘To UTM’, do not check the box “TL BR” – you will then see values fill 
in the upper right side in the box “Condor UTM Range”.

d) Then click “Check/Show” and you will see a grid pattern in the box labelled “Condor 
Latitude/Longitude”.    Explanation follows.
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The number is the upper right box are called Easting/Northing values.  The earth is divided into 60 
UTM zones, USAFA is in 13N, and your exact location in the zone is defined by the Easting(X Coord) 
and Northing(Y Coord).  So the values above express the exact coordinates of the corners and for our 
Condor landscape they need to be on whole numbers.

The bottom right box shows the rounding the rounding that occurred.  Our original values (the Blue 
Box) put us between a 3x3 and a 3x4 terrain.  The outer black grid shows the landscape has been 
expanded to 3x4.   We want 3x3 so we need to shrink it in Latitude.   With some new values in the 
Coordinates and then clicking on “To UTM” and “Check/Show” we finally get a 3x3 terrain (below).

We need to store the Easting/Northing values.

 NW Corner:  480968 (Easting), 4343659 (Northing)
 SW Corner:   550088 (Easting), 4274539 (Northing)
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3)  In the lower right click on “Make KML” to make a Google-earth map file.  It will be stored in 
Landscapes/NEW/working/DEM  (you’ll need Google Earth to see the file.  It should agree with what 
you expect. 

Step Three:  Download terrain data and create terrain files

1) Click on “Make DEM” to create a batch file to run the GDAL library routines.  Check the message 
box in the main Condor_tiles window for files you need to download.  
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At this point some files are being created for your new scenery.  Check the ../Working/DEM folders 
and you see the batch files (DEM.bat).   It contains the commands necessary to created the actual 3-D 
terrain for the area you specified.

2) You next need to download this data from a NASA website.  Will be use Space Shuttle Radar 
Topography Mission data (SRTM).

a) First go to → https://dwtkns.com/srtm30m/ 
You can zoom in to your location and then click to see the tile name, we need four tiles as 

shown in the message above: 
 N38W106.hgt, N38W105.hgt, N39W106.hgt, N39W105.hgt

b) When you click to download, you’ll first need to create a login account with NASA. Save the
files (.zip) in the DEM directory where the .bat file is located.  You should now have this directory 
contents:

 c/Condor2/Landscapes/NEW/Working/DEM>ls -l
total 44481
-rwxrwxr-x+ 1 jmurtari None     1879 Mar  5 12:17 DEM.bat
-rwxrwxr-x+ 1 jmurtari None  9136222 Mar  5 12:39 N38W105.SRTMGL1.hgt.zip
-rwxrwxr-x+ 1 jmurtari None 13588170 Mar  5 12:39 N38W106.SRTMGL1.hgt.zip
-rwxrwxr-x+ 1 jmurtari None  8403816 Mar  5 12:39 N39W105.SRTMGL1.hgt.zip
-rwxrwxr-x+ 1 jmurtari None 14409660 Mar  5 12:39 N39W106.SRTMGL1.hgt.zip
drwxrwxr-x+ 1 jmurtari None        0 Mar  5 11:55 OverAllMap
-rwxrwxr-x+ 1 jmurtari None      264 Mar  5 12:17 scenery.hdr

                                                                                                                    
c) Next unzip the files and you should have four .hgt files
d) Then run the DEM.bat file – you should see quite a bit of output .  The following new files 

should be created:
NOTE: you may see a few errors on files not found, similar to cropped.tif (they can be ignored).

-rwxrwxr-x    1 jmurtari UsersGrp   1181375 Mar  5 12:45 UTM_cropped_90m.tif
-rwxrwxr-x    1 jmurtari UsersGrp       604 Mar  5 12:45 UTM_cropped.raw.aux.xml
-rwxrwxr-x    1 jmurtari UsersGrp  10616832 Mar  5 12:45 UTM_cropped.raw
-rwxrwxr-x    1 jmurtari UsersGrp       680 Mar  5 12:45 UTM_cropped.hdr           
   

3) You done with Condor_tiles for now.  We next need to use one of the tools downloaded from the 
CondorSoaring website in Step Zero above.  Run the “RawToTrn” tool.

a) In the “Load” tab for Width/Height enter the ‘samples’ and ‘lines’ values from the 
UTM_cropped.hdr text file. Since our terrain is square they should be the same value, in this case 2304.
Only check the box for “Flip Vertical”. Accept the 30m resolution.

b) Then click on “Load raw heightmap” and you’ll find UTM_cropped.raw in the DEM 

Page 8 of 17

https://dwtkns.com/srtm30m/


directory.

c) After it loads, you should see something similar to the image below.  The cropped size 
should agree and the data grid should show some variation in color – that’s your terrain!
                 

d) There is no need to use the ‘Crop’ tab.  Next select the ‘Save’ Tab. Enter your UTM zone, in 
this case 13N.  Select “Top left” and enter the easting/northing values, in this case: NW Corner: 
480968 (Easting), 4343659 (Northing)

e)  Then click “Save to TRN” and place in the top directory with the same name as the 
landscape.
NOTE → In the filename, even though it shows the extensions .trn, you must enter that as part of the 
name, e.g. NEW.trn
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The following files were created:
/NEW.trn
/heightmaps – a series of files starting with h0000.tr3 – h1111.tr3

These contain the terrain data for each tile.  You should be asking if our terrain is 3x3, that 
should only be nine files, why are there a 144!!!?   Because…. Condor2 subdivides each of the larger 
tiles into 4x4 subtiles.  So 9 * 16 = 144.

How do you relate the numbers to the actual terrain location, check Appendix ONE for a 
complete explanation.  Real quick →  The bottom right tile is “0000”, the first two digits are the row, 
the second two are the column.  The tile to the left of the bottom right tile is “0001” and the tile above 
the bottom right is “0100”.  The tile in the upper right corner is “1111” (remember, total of 12 subtiles 
numbered 0-11).

Step Four:  Use the Condor Landscape Scenery Editor

In our last step we’ll actually finish creating a flyable terrain.  It won’t have any real scenery, 
but you’ll be able to see 3-D terrain and fly it in Condor2.

1) Copy the NEW.trn file currently in your /NEW/Working/DEM directory to the top level 
landscape directory, e.g. C:/Condor2/Landscapes/NEW  

2)  Start the Landscape Editor, and from the Landscape popdown in the upper right, you should 
see your new Landscape as an option.  If you don’t make sure you copied the NEW.trn file to 
the proper directory in the step above.  You should see something like below.
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How to maneuver.  As you move the mouse around, you are presented with a lot of useful 
location information in the bottom bar.  The latitude and longitude values should agree with 
what you’re expecting.   By default, the editor puts you near the middle of the terrain.  To move
around select the “FINGER” and you can drag the terrain.  Notice the yellow lines delimit the 
larger 3x3 tiles, and the dashed lines show the 4x4 subtiles.

Click the left mouse button to zoom in, middle/right to zoom out.

                                                                                                                                                                      

3) Next we’ll position our runway.  A landscape must have at least one Airport defined to be 
flyable in Condor 2.  Using another tool like Google Earth you need to find the exact LAT/LON
in decimal degrees for the middle of your runway, also the elevation (in meters).  Google Earth 
does give you the option of seeing decimal degrees and meters.

For USAFA I used:   38.972466 /  -104.82224  (THIS SHOULD BE THE MIDDLE/CENTER 
of the runway), elevation:  1989 meters, length: 1350 meters,  direction: 169 (True), width: 12 
m.                          

4) In the Landscape Editor, in the “View/Modify” box, check “Airports”.  Then put your mouse
in the blank area beneath and click right.  A menu should appear, select ‘Add’.   Then fill in the 
values and select OK.   It should appear on the map.

5) Now just complete the steps in the “Condor Landscape Guide”, briefly below:
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a) File → Export flightplanner map
b) File → Export forest map (it will be empty)
c)  File → Export thermal map (again, empty, but needed)

            d)  File → Export textures to DDS (As the guide says, you’ll need the Nvidia legacy 
texture tools placed in the same directory with the LandscapeEditor.exe for this to work.  Say 
‘No’ to export only nonexisting, we want everything recreated.
             e) File → Export terrain hash
             f) File → Export forest hash  (These steps are important as an anti-cheat mechanism. 
ALSO, if you ever try to fly Condor2 and your elevator doesn’t work, make sure you have 
exported these recently).

g) File → Save Landscape

Step Five:  Take a test flight in Condor 2

Just a little more to do.  

1) You still need two more files in the main landscape directory:

 NEW.ini – just copy the file from Slovenia2 and rename.  Edit the text file and change Version 
to be something meaningful, e.g. Version=USAFA 1.00

 NEW.cup – again copy and rename the file.  This is another text file, contains waypoint 
definitions. 

2)  Start Condor2 and select “FREE FLIGHT”.  In the upper right “Landscape” box you should now be 
able to select your scenery.

3)  TASK tab: You must define a simple task.  Click on “New” and then Click on your airport, move 
the mouse and it will create a line, Click again to create a turnpoint.  Just make a box, but end it by 
going to your airport and clicking again – you should get “Finish”

4)  NOTAM tab:  You can try an “Aerotow”, recommend change rope length to 200’.  We have not yet 
created a real airport, so the terrain and tow planes may not line up.  If it doesn’t work, choose 
Airborne.

5) “SAVE” the flightplan and then click “Start flight”
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Part Two:  Photo Scenery creation

Step Zero:  Download needed tools.

There is probably a way to do this for FREE and I’m happy to update the tutorial.  For now you’ll need 
to spend a little money for a tools that makes downloading satellite imagery easier.

Go to http://AllMapSoft.com/ and download the “Google Satellite Maps Downloader.”  To create HI-
RES scenery as we will in this case, you’ll need the paid version.

For Condor scenery generation, the concept is to get a set of these imagery tiles at a desired resolution 
for a given area to fit into Condor tiles of a desired resolution.   Review Appendix ONE for more info 
and a table of zoom/resolution in meters.

Step One – Create the commands necessary to download images

We’ll use Condor_Tiles for this step.

1) Start  Condor_Tiles 

     Pick the landscape name and Version should stay at V2.  
     Pick the type of data imagery (we'll be using Google).
     Pick the desired GMID zoom level (we'll use 16)
     Pick the desired tile size for Condor, which should match closely to the zoom level (8192)

 2) Click on Read the Header button to load the UTM data of the scenery extents

 ## You’ll get a Header File Not Found, okay to ignore as long as “Reading Terrain header”
You should see something like this in the message area:
Header File Not Found
Reading Terrain header...
UTM Zone:   13 N
UTM Bottom: 4274539
UTM Right:  550088
Height:     768
Width:      768
Resolution: 90
Delta X:    -90
Delta Y:    90
9 dummy centre tile airports created

  3) Click on the 'Make GMID' button to generate initial coordinate extent files for each tile.  These 
files will be used by the Maps Downloader.  Again, you can see the numbering coordinate system used 
for the files.  These are text files.  You will find them in the ./Working/SourceTiles
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CONFIRMATION CHECK:  Look at the contents of a file, the Lat/Lon coordinates should be 
as you expected.

                                               

Step Two:  Download the image data.

  1) Run the GoogleSatelliteMapsDownloader downloader.exe.

a) Click on "Open Task" and select the Initial_0000.gmid file.

b) After it opens change the "Task name;" box  (this is unusual...)
Initial_0000.gmid  to  0000.gmid  (YOU ARE NOT changing the actual file name, just the Task 

name.)

 c)  You should see LAT/LON values fill in (taken from the file), and they should make sense 
with your scenery location.

                                
  d) Click on "Start" to begin  the download process.
 You should see a "Downloaded" count in the lower left, it should eventually reach the "Total 
images" number.   If it seems to get stuck, or no progress, make sure you can reach the google site.

             e)   What's actually happening:

  - a folder 0000 will be created and a set files will be downloaded into that folde
  - these files are 256x256 images that cover the desired area, but actually cover more area than 
needed
  - at the end, the file 0000.gmid will contain the actual coordinate extent of the downloaded 
tiles 

 f) REPEAT the above steps for all 9 tiles – don't make any typos!

2)  Still in the downloader.  Select "Tools -> Map Combiner", that will take care of merging all the 
individual 256x256 files.   

a) Select the "0000.gmid" file (NOT the one prefixed with "Initial_") and untick all image types
except bitmap.

b) REPEAT for all 9 tiles.

When it's all done, you've created 9 .bmp files, one for each tile:
/cygdrive/c/Condor2/Landscapes/NEW>find . -name "*.bmp" -ls
   327680066 Mar  6 14:06 ./Working/SourceTiles/0000/0000_combined/0000.bmp
   327680066 Mar  6 14:07 ./Working/SourceTiles/0001/0001_combined/0001.bmp
   327680066 Mar  6 14:07 ./Working/SourceTiles/0002/0002_combined/0002.bmp
   327680066 Mar  6 14:07 ./Working/SourceTiles/0100/0100_combined/0100.bmp
   327680066 Mar  6 14:08 ./Working/SourceTiles/0101/0101_combined/0101.bmp
   327680066 Mar  6 14:09 ./Working/SourceTiles/0102/0102_combined/0102.bmp
   321126466 Mar  6 14:09 ./Working/SourceTiles/0200/0200_combined/0200.bmp
   321126466 Mar  6 14:10 ./Working/SourceTiles/0201/0201_combined/0201.bmp
   321126466 Mar  6 14:11 ./Working/SourceTiles/0202/0202_combined/0202.bmp
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 3)  All done with the downloader.  You can exit.

Step Three – convert images to Condor tiles

Now, this single image can be converted into a Condor tile, by 'warping' to UTM and 'cropping' to the 
desired size.

1) Start Condor_tiles. To create the batch file that will do this, on Condor_tiles, pick the desired tile in 
the "Tile" section,  0000 in this case, and click Make GDAL

  - a batch file GDAL_0000.bat will be created in the tile folder 0000
  - double-click on the batch file and it will process the data
  - a new image 0000.bmp will be placed into the Working/Terragen/Textures folder

REPEAT for each tile, 0001, 0002, etc... 
 You can do these simultaneously if your PC has the memory.  Each is independent.

Step Four – create the final scenery

1) Run the Landscape editor, and pick the landscape, and then in Tools, 'Import tile sized textures'
   - the images in Working/Terragen/Textures will be loaded as the imagery.
   - this will replace the initial black-and-white terrain based imagery.

2)  You can check your airport placement with the imagery, and carefully adjust the lat/lon for the 
proper position

3) In the Lanscape editor the run the same export commands as before.                                                    

a) File → Export flightplanner map
b) File → Export forest map (it will be empty)
c)  File → Export thermal map (again, empty, but needed)

            d)  File → Export textures to DDS (As the guide says, you’ll need the Nvidia legacy 
texture tools placed in the same directory with the LandscapeEditor.exe for this to work.  Say 
‘No’ to export only nonexisting, we want everything recreated.
NOTE: This will take some time now – 15-30 minutes
             e) File → Export terrain hash
             f) File → Export forest hash  (These steps are important as an anti-cheat mechanism. 
ALSO, if you ever try to fly Condor2 and your elevator doesn’t work, make sure you have 
exported these recently).

g) File → Save Landscape
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  APPENDIX ONE – General notes on Scenery Creation
by Nick Bonniere

1) A scenery is a made up of a group of tiles

2) Each tile is 23 km x 23 km (14.29 mi x 14.29 mi), which is actually a resolution
of 90 meters times 256 = 23.040 km
    
If you pick 4 tiles, I would suggest you offset the airport from the center a bit 
so it falls fully into one of the 4 tiles, otherwise it will be cut-up into 4 
pieces. Not absolutely necessary, just a suggestion so you can view the airport in 
one tile only.

3) The original resolution of 90 m is based on Space Shuttle elevation data (STRM)

4) Condor 2 uses a resolution of 30 meters, which is 3 times the resolution of 
Condor 1, and 30m STRM data is available

5) The last 1/4 tile edge of a scenery is not flyable. So if you have one tile, 
only the centre 1/2 or 11.5 km x 11.5 km is flyable, If you use 2 x 2 tiles, i.e 4 
tiles, 46 km x 46 km, only the centre 34 km x 34 km is flyable, etc...

6) The projection used is UTM, (Universal Transverse Mercator), This means that all
elevation data and photographic data needs to be converted to UTM coordinates. If 
you pick 4 tiles, I would suggest you offset the airport from the center a bit so 
it falls fully into one of the 4 tiles, otherwise it will be cut-up into 4 pieces. 
Not absolutely necessary, just a suggestion so you can view the airport in one tile
only.

7) Tiles are in a grid of rows and columns starting at the bottom right corner 
(South East), which is tile 0000. The first two digits are the column number and 
the second two digits are the row number. Above tile 0000.bmp is tile 0001.bmp. The
tile to the left is tile 0100.bmp

8) You can use multiple resolutions. For LakePlacid, the centre tile is hi-res 
8192x8192, while all the other tiles are 4096x4096.  The file size increases by a 
factor of 4, 48MB file (at 4096) instead of 192MB (at 8192).
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9) Notes on Tile system zoom level and Condor resolution

                                                                          
- Tile system zoom level  (approximately)
- zoom level 1 - each pixel is 78184 m (equator), 55284 m (45 deg latitude)
- zoom level 2 - each pixel is 39092 m (equator), 27642 m (45 deg latitude)
.....
- zoom level 10 - each pixel is 152.7 m (equator), 108.0 m (45 deg latitude)
- zoom level 11 - each pixel is  76.3 m (equator),  54.0 m (45 deg latitude)
- zoom level 12 - each pixel is  38.1 m (equator),  27.0 m (45 deg latitude)
- zoom level 13 - each pixel is  19.1 m (equator),  13.5 m (45 deg latitude)
- zoom level 14 - each pixel is   9.5 m (equator),   6.7 m (45 deg latitude)
- zoom level 15 - each pixel is   4.8 m (equator),   3.4 m (45 deg latitude)
- zoom level 16 - each pixel is   2.4 m (equator),   1.7 m (45 deg latitude)

- Condor resolution
- tile size  256 - 23040 m, each pixel is 23040/256  = 90 m
- tile size  512 - 23040 m, each pixel is 23040/512  = 45 m
- tile size 1024 - 23040 m, each pixel is 23040/1024 = 22.5 m
- tile size 2048 - 23040 m, each pixel is 23040/2048 = 11.25 m
- tile size 4096 - 23040 m, each pixel is 23040/4966 = 5.625 m
- tile size 8192 - 23040 m, each pixel is 23040/8192 = 2.8125 m
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